View Full Version : Also unable to download

07-11-2009, 10:48 AM
When I go to the main page and click "download maps" or "Download map packs" it brings me to the page offering "all maps"

So I check all maps, click the button at the bottom of the page and it sends me back to the "Mapfiend home page".

Over and over, all it does is send me back to the main page.

I thought it was because I was not registered or signed in, but nope.

Any clue?

New machine, vista64, all windows updates installed.


PS: This happens on individual maps also

07-11-2009, 11:10 AM
Same here, the exact same thing happens to me. I'm running 64bit Windows 7.

The same thing happens in both Google Chrome and Internet Explorer. Hope someone can fix this soon!

07-11-2009, 05:23 PM
Just fixed it. Try again. Thanks.

07-12-2009, 09:29 AM
Just fixed it. Try again. Thanks.

Thank you!

04-30-2012, 03:08 PM
This happens to me also...been reading many posts saying the same thing but it seems no-one has an answer for it :(

05-01-2012, 09:56 PM
I would rather not look at every single one to find the ones you are having problems with. It seems odd that you are the only person having these problems.